Urgent problem with web client login...

Forum to discuss the Web client version of Servoy.

Urgent problem with web client login...

Postby john.allen » Tue Apr 24, 2012 6:39 am

I am working on a solution in 6.0.6. Doing most of my development testing using smart client but some in web client especially when I have to check dialog box stuff as I'm working on a Mac. I'm therefore pretty sure this is something that just came about...

When I login using web client my login/password lets me in to the solution but none of the usual Servoy security functions work. So security.getUserName() for example returns null. Naturally this screws everything up. However in smart client this doesn't happen at all. Everything is fine. I thought I was almost done and ready to launch this live by the end of the week plus I have a demo tomorrow morning at 11 AM Pacific time. I'm totally bewildered. I tried uploading the solution to the server proper but I get exactly the same behavior: fine in smart, not in web client. If it helps I've pasted the output from the servoy-admin pages below although it just seems to be confirming running the same query in both and works in smart but not in web...

Any help would be greatly appreciated!

Here is the web client output (read from bottom up):
Loading messages from server: null table: null
Leave registerClient registered:false in 16 ms
Client (re)registered with id C89577FB-0AE6-435E-872F-EF818DE20443, previous: null
Loading messages from server: null table: null
questiondata[2] = 2 ,type: java.lang.Integer
questiondata[1] = 'mypassword==' ,type: java.lang.String
questiondata[0] = 'mylogin' ,type: java.lang.String
used sql select user_uid from servoy_users where user_name=? and user_password=? limit ? questiondata.length 3
QuerySet { prepares = <null>, select = select user_uid from servoy_users where user_name=? and user_password=? limit ? [[mylogin,mypassword==,2]] <0^2>, cleanups = <null> }
CUSTOM ELEMENT select user_uid from servoy_users where user_name=? and user_password=? ([mylogin,mypassword==]) FILTER null


Here is the same stuff when logging in via smart client:

used sql select distinct(sg.group_name) from servoy_groups sg,servoy_user_groups sug, servoy_users su where sg.group_id = sug.group_id and sug.user_id=su.user_id and su.user_uid=? order by sg.group_name limit ? questiondata.length 2
QuerySet { prepares = <null>, select = select distinct(sg.group_name) from servoy_groups sg,servoy_user_groups sug, servoy_users su where sg.group_id = sug.group_id and sug.user_id=su.user_id and su.user_uid=? order by sg.group_name limit ? [[1,501]] <0^501>, cleanups = <null> }
CUSTOM ELEMENT select distinct(sg.group_name) from servoy_groups sg,servoy_user_groups sug, servoy_users su where sg.group_id = sug.group_id and sug.user_id=su.user_id and su.user_uid=? order by sg.group_name ([1]) FILTER null
Analysing filters null
sql select CUSTOM ELEMENT select distinct(sg.group_name) from servoy_groups sg,servoy_user_groups sug, servoy_users su where sg.group_id = sug.group_id and sug.user_id=su.user_id and su.user_uid=? order by sg.group_name ([1])
questiondata[2] = 2 ,type: java.lang.Integer
questiondata[1] = 'mypassword==' ,type: java.lang.String
questiondata[0] = 'mylogin' ,type: java.lang.String
used sql select user_uid from servoy_users where user_name=? and user_password=? limit ? questiondata.length 3
QuerySet { prepares = <null>, select = select user_uid from servoy_users where user_name=? and user_password=? limit ? [[mylogin,mypassword==,2]] <0^2>, cleanups = <null> }
CUSTOM ELEMENT select user_uid from servoy_users where user_name=? and user_password=? ([mylogin,mypassword==]) FILTER null
Analysing filters null
sql select CUSTOM ELEMENT select user_uid from servoy_users where user_name=? and user_password=? ([mylogin,mypassword==])
John Allen
Stanford University
john.allen
 
Posts: 511
Joined: Wed Jul 02, 2003 10:07 pm
Location: Stanford CA USA

Re: Urgent problem with web client login...

Postby john.allen » Tue Apr 24, 2012 10:06 pm

Just to be clear, this is just using the vanilla Servoy login, no separate login/authentication modules. I'm going to enter it in the bug system with an attached solution.
John Allen
Stanford University
john.allen
 
Posts: 511
Joined: Wed Jul 02, 2003 10:07 pm
Location: Stanford CA USA

Re: Urgent problem with web client login...

Postby rgansevles » Tue May 22, 2012 10:16 am

This is fixed in the next 6.0 release of Servoy.

Rob
Rob Gansevles
Servoy
User avatar
rgansevles
 
Posts: 1854
Joined: Wed Nov 15, 2006 6:17 pm
Location: Amersfoort, NL

Re: Urgent problem with web client login...

Postby wvitpr » Sat Jul 21, 2012 6:54 pm

Is there any work around for this problem in Version 5.2.14, we are not ready to move to 6.0 and I really need the built in security functions to work in webclient urgently.
Regards,
Phillip Routley

Worldview IT
Sydney, Australia
User avatar
wvitpr
 
Posts: 159
Joined: Tue Apr 24, 2007 1:38 am

Re: Urgent problem with web client login...

Postby rgansevles » Mon Jul 30, 2012 9:16 am

Phillip,

The problem is forms with property loginFormID:"-1"
If you search for these in the solution_settings.obj files of your workspace and remove that line, followed by a workspace refresh (solution explorer view has a refresh button), it should work ok.

Btw, I have backported the fix to 5.2 now as well.

Rob
Rob Gansevles
Servoy
User avatar
rgansevles
 
Posts: 1854
Joined: Wed Nov 15, 2006 6:17 pm
Location: Amersfoort, NL

Re: Urgent problem with web client login...

Postby wvitpr » Thu Aug 02, 2012 2:25 am

Hi Rob,
Thank you.. will there be a new release of 5.2 that includes this fix soon.
Regards,
Phillip Routley

Worldview IT
Sydney, Australia
User avatar
wvitpr
 
Posts: 159
Joined: Tue Apr 24, 2007 1:38 am


Return to Servoy Web Client

Who is online

Users browsing this forum: No registered users and 1 guest

cron